Erro: Não existem chaves públicas para os seguintes IDs de chaves.

Tempo de leitura: 1 minuto

E ai, tudo bem? Esses dias fui atualizar um servidor Debian e ao executar o comando ele apresentou um erro: Não existem chaves públicas para os seguintes IDs de chaves.

O erro acontece porque existe no sistema algum pacote não oficial instalado e na hora de atualizar ele não consegue verificar a autenticidade do download e por segurança não faz a atualização.

O problema pode ser resolvido importando as chaves necessárias para que a autenticação seja feita e é isso que eu quero te ensinar hoje.

Mãos na massa

Para importar as chaves necessárias, pegue o ID apresentado junto com o erro e execute os seguintes comandos:

Obs: No campo <id> substitua pelo ID apresentado junto com o erro.

Mais uma dica

Se você tiver várias chaves para importar, você pode usar o comando abaixo para resolver tudo de uma vez, só precisa colocar os IDs exibidos nos erros apresentados no lugar de ID1ID2 e ID3 (do exemplo abaixo) separados por espaço.

 

Bom, é isso, espero que tenha ajudado e que você tenha gostado do conteúdo.

Um grande abraço e nos vemos no próximo post.

Testado no Debian 7.8

Precisa de Suporte Técnico ou Consultoria? Acesse www.revolutech.com.br

Gostou? Compartilhe, deixe seu comentário e se inscreva na nossa lista para receber novidades e conteúdos exclusivos por Email.

Achou algum erro? Precisa de ajuda? Criticas? Deixe seu comentário.

Obrigado!

  • Consegui resolver o meu problema desinstalando o ofensor.
    usei o comando: apt-get remove –purge "coloque aqui"

    onde coloquei dentro das aspas o nome do problema, mas depois tira as aspas..